29 Dez

They’re taking the Horde to Debian, to Debian!

Now that Horde Groupware 5 has been released as stable software, a lot of users noticed the shortcomings of the PEAR packaging systems. It does not provide an easy and smooth way to upgrade Horde 4 to the latest bugfix version anymore. If you run Horde 4 apps that have not been ported for Horde 5 yet, you need to be very cautious which pear commands you run. A simple pear upgrade -c horde would break your existing installation because it would upgrade everything to the most recent major version. This is not desirable for production systems. Distribution packaging is the solution to this. Receive only compatible upgrades until you decide to do a major upgrade.

Distribution packages of Horde 5 are available for openSUSE and SUSE Linux Enterprise Server from the isv:B1-Systems:Horde5:rolling project.

These packages include development snapshots of unreleased applications like Passwd for Horde 5. They have been modified to fit into the distribution specific standard directories, install regular jobs the distribution way etc. For example, the distribution apps don’t have separate .htaccess files but provide a ready-to-run apache2 vhost config.

Under debian however, nobody stepped up to help the main debian horde packager, Mathieu Parent, to finish the Horde 5 packages in time. This means, the next stable Debian release will probably not include Horde 5.

I have talked to Mathieu and built a patch for the Open Build Service which facilitates PEAR packaging for debian targets.

You can see the progress of debian packaging by adding the Debian repository of the project to your /etc/apt/sources.list file

cd /root/
echo "deb http://widehat.opensuse.org/repositories/isv:/B1-Systems:/Horde5:/rolling/Debian_6.0 ./" >> /etc/apt/sources.list
wget http://download.opensuse.org/repositories/isv:/B1-Systems:/Horde5:/rolling/Debian_6.0/Release.key
apt-key add Release.key
apt-get update

As of today, the repository only contains php-horde-autoloader but it I aim to fill it with all ~ 100 Horde pear packages (minus the bundles).

If you need business critical, supported Horde 4 or Horde 5 packages for openSUSE/SLES, Redhat/CentOS, Debian, Ubuntu or special architectures like ARM or Itanium, don’t wait for community action but ask for a commercial solution.

Mathieu Parent sagt:

Great!

Note that most of Horde packages are now in Debian unstable [1], and they can be installed from there to Debian wheezy (and maybe squeeze). I still need to update instructions on https://wiki.debian.org/Horde.

[1]: http://packages.debian.org/search?suite=default&section=all&arch=any&searchon=sourcenames&keywords=php-horde

Mathieu Parent sagt:

Instructions to use packages from Debian repositories are at: https://wiki.debian.org/Horde

Nick Bebout sagt:

We are making quite a bit of progress on getting Horde in Fedora and EPEL (Extra Packages for Enterprise Linux). We are hoping to have all of it packaged before Fedora 19 is released in June.

http://rpms.famillecollet.com/rpmphp/rpm.php?type=pear&what=%23horde shows what is available currently. (or you can use the usual tools like yum and pkgdb and koji to look up the packages also)

Ralf sagt:

This is great news 🙂

SolarBoy sagt:

I had an issue when installing that was very difficult to find a fix for using web search engines. After running webmail-install and entering my info for using PostgreSQL, it got this error:
Creating and updating database tables…
====================

Fatal Error:
Could not instantiate PDO with DSN „pgsql:dbname=DATABASE-NAME-USED“. PDOException: could not find driver
In /usr/share/php/Horde/Db/Adapter/Pdo/Base.php on line 46

1. Horde_Core_Bundle->migrateDb() /usr/bin/webmail-install:32
2. Horde_Core_Db_Migration->getMigrator() /usr/share/php/Horde/Core/Bundle.php:102
3. Horde_Injector->getInstance() /usr/share/php/Horde/Core/Db/Migration.php:90
4. Horde_Injector->createInstance() /usr/share/php/Horde/Injector.php:247
5. Horde_Injector_Binder_Factory->create() /usr/share/php/Horde/Injector.php:213
6. Horde_Core_Factory_DbBase->create() /usr/share/php/Horde/Injector/Binder/Factory.php:111
7. Horde_Core_Factory_Db->create() /usr/share/php/Horde/Core/Factory/DbBase.php:17
8. Horde_Core_Factory_Db->createDb() /usr/share/php/Horde/Core/Factory/Db.php:99
9. Horde_Db_Adapter_Base->__construct() /usr/share/php/Horde/Core/Factory/Db.php:156
10. Horde_Db_Adapter_Pdo_Pgsql->connect() /usr/share/php/Horde/Db/Adapter/Base.php:143
11. Horde_Db_Adapter_Pdo_Base->connect() /usr/share/php/Horde/Db/Adapter/Pdo/Pgsql.php:88

====================

Turns out I did not have all the prereqs, I needed php5-pgsql. Same issue happens when you do not have php5-mysql installed. Hope this helps some one.

Ralf sagt:

Hi Steve,

the test suite (http://domain/test.php) shows you this kind of optional requirements. You need to enable it in horde/config/conf.php ($testdisable=false); Don’t forget to disable it later on.

Reini Urban sagt:

You will be pleased to hear that the next major cPanel release will update horde from 1.22 to 5.1 as rpm’s.
cPanel runs on centos 5+6 and is used by most webhosting companies.
Some technical problems with the rpmification though with running some parts of
`pear upgrade horde/webmail` in the postinstall script.
Who is the best contact and how?

Ralf sagt:

That’s great news.
You can always ask me directly via mail or on the horde community list if there is anything specific.
You can also take a look at the openSUSE build service rpms for horde.